WPVulnerability

Descripción

This plugin taps into the power of the free and unlimited WordPress Vulnerability Database API to deliver vulnerability assessments directly within your WordPress dashboard. It’s an essential tool for website administrators, developers, and anyone keen on maintaining a secure WordPress environment.

Secure your WordPress experience today, your first line of defense against vulnerabilities!

Comprehensive Security Analysis

  • Core: Checks the version of your WordPress Core against known vulnerabilities, ensuring you’re always aware of potential risks.
  • Plugin: Evaluates all your installed plugins, including those from the official repository, external sources, or premium ones, for any security weaknesses.
  • Theme: Evaluates all your installed themes, including those from the official repository, external sources, or premium ones, for any security weaknesses.
  • PHP: Analyzes your server’s PHP version, detecting vulnerabilities specific to your PHP setup. This is crucial as outdated or unsupported PHP versions can significantly increase security risks.

In-Depth Vulnerability Reporting

Stay ahead of potential threats with detailed reports. If a vulnerability is detected, visit the ‘Site Health’ section in your WordPress dashboard for in-depth information. It informs you about the nature of the vulnerability and provides guidance, such as updating to a newer version or addressing issues with unsupported or unpatched plugins/themes.

Customizable Alert System

Configure the plugin to send periodic notifications about your site’s security status. Choose between daily or weekly updates, ensuring you’re always in the loop about your website’s vulnerability status without being overwhelmed by information.

Why Choose This Plugin?

  • User-Friendly: Designed for ease of use; no technical expertise required.
  • Proactive Security: Helps in early detection and resolution of security issues.
  • Peace of Mind: Ensures you’re always a step ahead in maintaining a secure WordPress site.
  • Privacy-Conscious: The plugin operates with a strong commitment to privacy. It does not store any data from your site nor retrieves personal or sensitive information.
  • Respect for Data Integrity: We understand the importance of your site’s integrity. The plugin works discreetly in the background, ensuring that your content and data remain untouched and unaffected during security checks.

WP-CLI

And then, You will find these wpcli commands:

  • wp wpvulnerability --help: Get help with these commands.
  • wp wpvulnerability core: List Core vulnerabilities.
  • wp wpvulnerability plugins: List Plugins vulnerabilities.
  • wp wpvulnerability themes: List Themes vulnerabilities.
  • wp wpvulnerability php: List PHP vulnerabilities.

Fiabilidad de los datos

La información proporcionada por la base de datos proviene de diferentes fuentes que han sido revisadas por terceros. No existe ningún tipo de responsabilidad sobre la información. Actúa por tu cuenta y riesgo.

Compatibility

  • WordPress 4.1 – WordPress 6.5.
  • PHP 5.6 – PHP 8.3.
  • WordPress Coding Standards 3.0.1.
  • WP-CLI 2.3.0 – WP-CLI 2.10.0.

Security

This plugin adheres to the following security measures and review protocols for each version:

Privacy

  • This plugin or the WordPress Vulnerability Database API does not collect any information about your site, your identity, the plugins, themes or content the site has.

Vulnerabilities

  • No vulnerabilities have been published up to version 3.1.1.

Found a security vulnerability? Please report it to us privately at the WPVulnerability GitHub repository.

Contributors

You can contribute to this plugin at the WPVulnerability GitHub repository.

Capturas

  • WP-Admin Dashboard widget.
  • Vulnerability list at Site Health.
  • Vulnerability list at Plugins list.

Instalación

Descarga automática

Visita la sección de plugins en tu WordPress, busca [wpvulnerability] y descarga e instala el plugin.

Descarga manual

Extrae el contenido del ZIP y sube el contenido al directorio /wp-content/plugins/wpvulnerability/. Una vez subido, aparecerá en tu lista de plugins.

FAQ

¿De dónde procede la información sobre vulnerabilidades?

El origen está en la API de WPVulnerability.com. Las vulnerabilidades que aparecen en esta API provienen de diferentes fuentes, como los CVE.

¿Se envían los datos de mi sitio a alguna parte?

No. Nunca. Tu privacidad es muy importante para nosotros. No comerciamos con tus datos.

¿Qué vulnerabilidades voy a encontrar?

Vulnerabilities in WordPress Core, Plugins, Themes, and PHP are documented.

¿Qué hago si mi sitio tiene una vulnerabilidad?

En primer lugar, tranquilidad. Investiga cuál es la vulnerabilidad y, sobre todo, comprueba que tienes la última versión del elemento comprometido. Te recomendamos activamente que mantengas actualizado todo tu WordPress y sus plugins.

Reseñas

21 de febrero de 2024
This plugin alerts you about known vulnerabilities in your WordPress core, plugins, themes, and even PHP, so you can take action in a timely manner. If you don't have this plugin on your site already, you absolutely need it!
4 de febrero de 2024
Este plugin es de los primeros que instalo en cada proyecto que ejecuto. Tanto para proyectos desde cero y con mucha más razón para corrección de fallos en proyectos iniciados.
26 de enero de 2024
Sin duda alguna, es el plugin que te ayuda estar informado de vulnerabilidades. Uno de los plugins que instalo por defecto en cuanto empiezo una web.
12 de diciembre de 2023 1 respuesta
Me encanta este plugin. Funciona perfectamente y es una herramienta imprescindible para los que somos amantes de la seguridad y de mantener nuestras webs lo más actualizadas y seguras posibles. Muchas gracias al equipo detrás de este espectacular plugin.
29 de mayo de 2023
I begint usisng the API for check some infected sites. Now In the form of Plugin, I installed in all my sites, and in the sites of customers
Leer todas las 14 reseñas

Colaboradores y desarrolladores

«WPVulnerability» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«WPVulnerability» ha sido traducido a 13 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «WPVulnerability» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

[3.1.1] – 2024-02-11

Fixed

  • Fixes some possible PHP warnings when retrieving data from the API.
  • Delete old schedules when unistalling the plugin.
  • Fix how is printed the High severity.

Deleted

  • The plugin will not show the Exploitability information.

Compatibility

  • Compatibility: WordPress 4.1 – WordPress 6.5.
  • Compatibility: PHP 5.6 – PHP 8.3.
  • Compatibility: WordPress Coding Standards 3.0.1.
  • Compatibility: WP-CLI 2.3.0 – WP-CLI 2.10.0.

[3.1.0] – 2024-02-04

Added

  • A new column in the plugin list, with the last updated day (and diff).
  • A notice if the plugin is closed in the WordPress.org repo.

Fixed

  • Fixes the schedule in some cases.
  • Fixes the PHP format (using always the n.n / n.n.n format).

Compatibility

  • Compatibility: WordPress 4.1 – WordPress 6.5.
  • Compatibility: PHP 5.6 – PHP 8.3.
  • Compatibility: WordPress Coding Standards 3.0.1.
  • Compatibility: WP-CLI 2.3.0 – WP-CLI 2.9.0.

[3.0.2] – 2024-01-27

Fixed

  • Fixes the WordPress Multisite saving options.

Compatibility

  • Compatibility: WordPress 4.1 – WordPress 6.5.
  • Compatibility: PHP 5.6 – PHP 8.3.
  • Compatibility: WordPress Coding Standards 3.0.1.
  • Compatibility: WP-CLI 2.3.0 – WP-CLI 2.9.0.